Welcome! Log In Create A New Profile
Show your ad here! Mail admin@walletfriendlywatchforum.com for rates
Show your ad here! Mail admin@walletfriendlywatchforum.com for rates


Advanced
Angry Just realised I can no longer use my version of Photoshop Elements 11, now that I have the Nikon D610 Angry
avatar October 01, 2014 04:57AM
The D610 is only supported in Adobe Camera Raw 8.1 onwards. However, Photoshop Elements won't update newer versions than Raw 7.3, so Adobe is forcing me to buy a new version of Elements Angry I probably won't buy a new version as I've hardly used it since I got Lightroom... I just wanted to do an HDR from RAWs with Elements Crying
Subject Author Views Posted
Angry Just realised I can no longer use my version of Photoshop Elements 11, now that I have the Nikon D610 Angry Micha 2957 October 01, 2014 04:57AM
I have Elements 12 and only use it to crop and clone when I can't in LR5. Use LR5 Thumbs Up Thumbs Up Smile (n/t) Cmoy 2784 October 01, 2014 06:32AM
I've hardly used Elements since I've started using LR5, but creating an HDR from 3 RAWs is the one thing LR5 can't do Angry (n/t) Micha 2756 October 01, 2014 06:56AM
Export them from LR as TIFF's and HDR it in Elemtns. The only thing I don't like about Elements is... Cmoy 2775 October 01, 2014 07:18AM



Sorry, only registered users may post in this forum.

Click here to login

  Our thanks to our WF-WF Sponsors!
Show your ad here! Mail admin@walletfriendlywatchforum.com for rates